Alura > Cursos de DevOps > Cursos de Redes > Conteúdos de Redes > Primeiras aulas do curso Redes: implementando roteamento, DNS e IPv6

Redes: implementando roteamento, DNS e IPv6

Roteamento interno - Apresentação

Lucas: Olá! Meu nome é Lucas e sou instrutor aqui na Alura.

Audiodescrição: Lucas é uma pessoa branca, com cabelos e barba pretos, usa óculos e está no estúdio da Alura, cujo fundo exibe uma estante com alguns itens decorativos, incluindo livros e plantas, e uma iluminação azul e roxa.

Nesta ocasião, teremos a companhia do instrutor Leonardo Sartorello.

Audiodescrição: Leonardo Sartorello é um é uma pessoa de pele clara, com olhos azuis. Tem cabelos castanhos escuros curtos e barba. Veste camiseta azul marinho e lisa, e está sentado em uma cadeira preta. Ao fundo, há um quadro pendurado em uma parede branca iluminada por uma luz azul e roxa.

Leonardo: Boas-vindas ao curso de redes!

Lucas, para quem será este conteúdo?

Para quem é esse conteúdo?

Lucas: Este conteúdo é destinado a você, que está aprofundando seu conhecimento na configuração e funcionamento de redes de computadores. Exploraremos o funcionamento detalhado de uma rede de computadores, conectada à internet.

Para acompanhar melhor o curso, sugerimos que você tenha concluído os cursos listados aqui como pré-requisitos.

Leonardo: E, Leonardo, o que vamos aprender ao longo desse curso?

O que vamos aprender?

Leonardo: Vamos verificar como funcionam os protocolos de roteamento interno e externo no direcionamento de pacotes entre diversas redes. Vamos configurar os servidores DNS, usar a versão 6 do protocolo de IP, também conhecida como IPv6, e ver como podemos integrar o IPv4 e o IPv6 na mesma rede, avaliando suas diferenças.

E, Lucas, como vamos explorar tudo isso?

Lucas: De modo bastante prático, utilizaremos uma ferramenta de simulação em teste, o Cisco Packet Tracer (Software de Simulação de Redes), e nela iremos dar continuidade no projeto de rede para o Instituto de Nova E.

Leonardo: Está animado para este curso?

Lembre-se de aproveitar todos os recursos da plataforma. Além dos vídeos, vamos ter atividades extras e apoio do fórum e da comunidade do Discord. Então, vamos nesse passo da jornada no mundo de redes?

Lucas: Vamos lá!

Roteamento interno - Como ocorre o roteamento?

Lucas: Fomos contratados, Léo, pelo Instituto Inovae para construir a rede de computadores da instituição.

Leonardo: Legal! Preciso saber, Lucas, quais os requisitos dessa rede.

Relembrando o projeto

Lucas: No projeto que construímos no curso anterior, a rede apresenta conexão com a internet, suporte para mais de 600 dispositivos conectados, segmentação entre os diferentes setores que constituem o Instituto.

Além disso, temos um servidor com acesso mais restrito (Políticas de acesso), pois armazena dados sensíveis da instituição e das pessoas colaboradoras. Também precisamos suportar um serviço de VolP.

Leonardo: Tudo isso já está configurado, mas surge um questionamento: como o computador do pesquisador A consegue acessar algo que está no provedor de serviços, que está na internet?

Roteamento

Lucas: Quem entra em campo nesse processo é o roteamento.

O roteamento é o processo de encaminhamento e definição das rotas pelas quais os pacotes de dados serão utilizados nas redes.

E, como em todas as situações de redes, nesse processo temos protocolos específicos para o roteamento.

Vamos ver isso na prática.

Vamos começar incrementando a rede do nosso provedor de serviços. Até agora, temos um roteador. Na prática, sabemos que temos milhares de dispositivos, e milhares de roteadores constituem uma rede.

Adicionando novos dispositivos no projeto

Então, vamos adicionar um novo roteador, um servidor e um switch no nosso projeto. Para incrementar a rede do provedor de serviços, usaremos os mesmos modelos que já usamos.

Leonardo: Usaremos o roteador 1841, o switch 2950-24 e um servidor (Server). Todos selecionados na parte inferior esquerda do Cisco Packet Tracer para determinar o tipo de equipamento.

Adicionando as conexões entre os novos dispositivos

Lucas: Feito isso, faremos a conexão usando os cabos aos quais estamos acostumados. Para isso, clicamos no ícone de raio e depois no cabo "Copper Cross-Over".

Logo após, selecionamos o "1841 - Provedor de serviços" e clicamos com o botão direito. Escolhemos a opção "FastEthernet0/0" no projeto e arrastamos até "1841 - Router0". Em seguida, clicamos com o botão direito em "1841 - Router0" e selecionamos a opção "FastEthernet0/0".

Posteriormente, selecionamos o cabo "Copper Straight-Through" e clicamos com o botão direito do mouse no dispositivo "1841 - Router0". Escolhemos a opção "FastEthernet0/1" e arrastamos para o "2950-24 - Switch0". Em seguida, clicamos com o botão direito no "2950-24 - Switch0" e selecionamos a opção "FastEthernet0/1".

Novamente, na parte inferior selecionamos o cabo "Copper Straight-Through" e clicamos no dispositivo "2950-24 - Switch0" com o botão direito do mouse. Escolhemos a opção "FastEthernet/0" no projeto e arrastamos até o dispositivo "Server-PT - Server0". Selecionamos o botão direito neste dispositivo e escolhemos a opção "FastEthernet0/".

Leonardo: Usamos Cross-Over entre os roteadores, e o normal entre o roteador switch e o switch servidor.

Lucas: Finalizamos as conexões físicas, não é, Leo?

Leonardo: Isso, agora vamos configurar a parte de redes.

Lucas: Isso. Estudamos e aprendemos os endereços IP anteriormente, mas para facilitar, vamos usar o processo de definição que analisamos anteriormente no caso do provedor de serviços e do Instituto Inovae, para fazer a conexão entre os dois roteadores que já estavam no projeto.

Usaremos, em nosso projeto, as duas sub-redes que ainda não foram usadas: a sub-rede 2 para conexão entre os roteadores e a sub-rede 3 para conexão entre o roteador e o servidor que acabamos de adicionar.

IP da Rede: 150.1.1.0

Máscara de rede: 255.255.255.252

IP sub-rede 1: 150.1.1.0

IP broadcast sub-rede 1: 150.1.1.3

IP sub-rede 2: 150.1.1.4

IP broadcast sub-rede 2: 150.1.1.7

IP sub-rede 3: 150.1.1.8

IP broadcast sub-rede 3: 150.1.1.11

Para facilitar nosso diálogo ao longo do curso, vamos renomear esses dispositivos.

Renomeando os dispositivos

Lucas: Clicamos duas vezes no dispositivo "1841 - Provedor de serviços" e digitamos "ISP 1 - A", sendo o roteador A. Na sequência, damos duplo clique em "1841 - Router0" e nomeamos para "ISP 1 - B".

O ISP 1 é de provedor de serviços 1, logo menos vamos entender melhor o motivo. Na sequência, selecionamos o dispositivo "Switch0" para "Switch ISP1". E no dispositivo "Server0" renomeamos para "Server ISP1".

Configurando as redes

Lucas: Depois de nomeados, vamos entrar no processo de configuração na aba CLI, começando pelo roteador A. Para isso, clicamos duas vezes no dispositivo "ISP 1 - A" e selecionamos a aba "CLI" na parte superior.

Digitamos "enable" e teclamos "Enter". Começaremos ativando a interface FastEthernet 0/0 com o comando no shutdown.

no shutdown

Como retorno, temos:

Interface FastEthernet0/0, changed state to up

E usaremos o comando IP address para atribuir o endereço para essa interface, da sub-rede 2. Adicionaremos também a máscara de rede ajustada, que usamos para definição desses endereços IPs.

ip address 150.1.1.5 255.255.255.252

Com isso, já configuramos o roteador A, vamos para o roteador B clicando no dispositivo "ISP 1 - B" e posteriormente na aba "CLI". No modo diálogo digitamos "no" e logo após rodamos "enable".

Na sequência, rodamos os seguintes comandos, respectivamente:

configure terminal
interface Fa0/0
no shutdown

Ativando a interface FastEthernet0/0, está conectada no roteador A. Atribuímos o IP address, que será o 150.1.1.5.

ip address 150.1.1.5 255.255.255.252

Saindo dessa interface com o comando exit, e aproveitar que já estamos nesse roteador B e configurar também a outra interface, que é a FastEthernet 0/1 usando o comando interface Fa0/1.

interface Fa0/1

Utilizamos o comando no shutdown para ativá-la.

no shutdown

Vamos atribuir o endereço da sub-rede 3 nesse caso, que será o 150.1.1.9.

ip address 150.1.1.9 255.255.255.252

Agora, faremos o mesmo processo no servidor.

Clicamos em "Server-PT - Server ISP1", logo após entraremos na aba "Desktop" e selecionamos "IP Configuration". Usaremos o 150.1.10. Inserimos a máscara de rede ajustada.

E o default gateway, que é importante, que é o ponto de saída da rede, que é justamente o endereço da interface do roteador em que este servidor está conectado, que acabamos de atribuir ao roteador B.

Podemos fechar essa janela.

Nesse ponto, já configuramos a rede do provedor de serviços, Léo.

Leonardo: Vamos fazer um teste para ver como será essa parte de roteamento. Vamos de pesquisador A até o servidor 1.

Lucas: Legal, clicando no computador do pesquisador A do projeto e posteriormente na aba "Desktop". No prompt de comando, pingamos 150.1.1.10, que é o endereço do servidor que acabamos de configurar.

ping 150.1.1.10

Temos como retorno:

Reply from 172.16.0.1 with 32 bytes of data

Oh, Léo, apareceu um erro: Destination Host Unreachable (Destino do Host Inalcançável), o que significa que esse host não pode ser alcançado pela nossa rede.

Vamos analisar o roteador 1 clicando em "Router1" e depois na aba "CLI", que é o roteador do Instituto InovaE.

Temos um comando, Léo, se entrarmos no "Enable" e enviarmos o show ip route, teremos acesso à tabela de roteamento do nosso roteador.

show ip route

O que é essa tabela de roteamento? São todas as rotas que estão configuradas no roteador. Ou seja, é o que o roteador consulta para que ele consiga encaminhar os pacotes e decidir qual será a melhor rota.

Nesse caso, observamos que a sub-rede na qual está inserido o servidor não está listada. Temos apenas as redes que estão diretamente conectadas nas interfaces desse roteador.

Portanto, precisamos adicionar de alguma forma essa rota. Vamos entrar no modo de configuração rodando os seguintes comandos, respectivamente:

enable
configure terminal

Usando o comando IP Route, inserimos o endereço da sub-rede 3 que utilizamos para configurar a rede entre o servidor do provedor de serviços 1 e o roteador B, isto é, 150.1.8, a máscara de subrede ajustada 252.

ip route 150.1.1.8 255.255.255.252

E agora, além do endereço da sub-rede, devemos especificar a interface para o qual nosso roteador deve encaminhar esse pacote. Nesse caso, será a interface serial 0/1/0, que é a interface de conexão entre os roteadores do Instituto InovaE e do provedor de serviços, o roteador A.

ip route 150.1.1.8 255.255.255.252 serial 0/1/0

E teclamos "Enter".

Aparentemente deu certo, damos um "Ctrl + Z". E agora já no enable, damos um Show IP Route para verificar se foi configurado.

show ip route

Observe, Léo, já temos esse endereço dessa rede. E observe que está indicando que pacotes, mensagens destinadas a essa rede devem ser enviadas por essa interface, que é a serial 0/1/0.

150.1.1.8 is directly connected, Serial0/1/0

Fechamos essa janela. E podemos tentar novamente, clicando em "Route1" e depois na aba "Command prompt" e fazer o mesmo teste, pingando 150.1.10.

ping 150.1.1.10

Vamos ver o que acontece. Obtemos:

Reply from 150.1.1.1: Destination host unreachable

O mesmo erro ocorre. O que será? Poderíamos verificar a tabela de roteamento do roteador A, do provedor de serviços, para verificar o que está acontecendo, já que o pacote chega até lá. Para isso, selecionamos "ISP1-A" e depois "CLI".

Em seguida, damos um Exit, "Ctrl + Z" e show ip route também.

exit
show ip route

O que observamos, Léo, é que essa rota, essa sub-rede, não está listada na tabela de roteamento desse roteador.

Leonardo: Bem, ela não consta. Poderíamos só colocar manualmente, acredito que para este caso específico funcionaria. Mas, cada vez que colocássemos algo novo, teríamos que atualizar isso, certo? E fazer isso manualmente não é o ideal.

Existe uma maneira de automatizarmos esse processo?

Lucas: Sim, Léo. Os protocolos de roteamento cuidarão disso para nós. Vamos estudar isso a seguir?

Roteamento interno - Entendendo o protocolo RIP

Leonardo: Lucas, antes de começarmos a trabalhar sobre os protocolos, notei que nós colocamos o mesmo endereço de B no ISP1-A e ISP1-B. Vamos corrigir isso?

Corrigindo o endereço do roteador B

Lucas: Ah, vamos sim, Léo. Bem lembrado. Vamos entrar na série do roteador B, no modo de configuração. Para isso, clicamos no dispositivo "ISP 1 -B", na aba "CLI".

Leonardo: Digitamos enable, depois rodamos configure terminal. Na utilização da interface, que é a Fast 0/0. E é necessário trocar o endereço de 150.1.1. 6. Também precisamos colocar a máscara.

enable
configure terminal
interface Fa0/0
ip address 150.1.1.6 255.255.255.252

Lucas: Perfeito, está tudo certo na nossa rede.

Leonardo: Agora os roteadores podem começar a interagir. Eles devem interagir de algum modo. Atuando em conjunto para rotear os pacotes. Como se fossem uma única entidade para poder fazer esse controle.

Entendendo o protocolo RIP

Lucas: Exatamente, Léo. Por exemplo, podemos usar o protocolo RIP na rede do provedor de serviços Zoom.

RIP = Routing Information Protocol (Protocolo de informação de roteamento)

Como o protocolo atua? Os roteadores vão compartilhar informações de roteamento entre si, compartilhando quais rotas cada um conhece.

Dessa forma, o roteador A vai saber quais redes o roteador B conhece. Assim, vai poder decidir se vai encaminhar um pacote para o roteador B ou não.

Vamos configurar o protocolo RIP na prática.

Configurando o protocolo RIP

Começaremos pelo roteador A do provedor de serviços (ISP1 - A). Vamos entrar no modo de configuração com o comando enable e configure terminal.

enable
configure terminal

E para ativar o comando RIP, usamos o comando router rip e rodamos.

router rip

E agora precisamos fazer uma coisa, né Léo? Que é especificar a versão do protocolo que desejamos usar. Nesse caso, será a versão 2. Então digitamos version 2 e rodamos.

version 2

Existe algum outro comando que devemos usar aqui, Léo?

Leonardo: Para o RIP funcionar adequadamente, é importante usarmos o no auto-summary.

Esse comando indica que o protocolo não realizará alguns resumos de tabelas e evitará algumas simplificações que poderiam comprometer o roteamento, o que pode ser problemático quando começarmos a efetivamente encaminhar pacotes de um local para outro.

Lucas: Boa! Então, vamos incluir aqui o no auto-summary e teclar "Enter". Ótimo!

no auto-summary

Depois do no auto-summary, Léo, o que devemos fazer?

Leonardo: Vamos começar a divulgar as redes.

Divulgando as redes

Leonardo: Começaremos com a rede do network, e temos que colocar o comando. Então ficamos com network 150.1.1.0.

network 150.1.1.0

E também a rede 150.1.1.4.

network 150.1.1.4

Lucas: Boa! Então já divulgamos essas duas redes. Acredito que sejam apenas essas duas que vamos divulgar desse roteador aqui.

Leonardo: Neste momento, sim. Agora temos que ir para o outro roteador, para o ISP 1 - B.

Lucas: Podemos fechar essa janela e vamos replicar basicamente o processo.

Clicamos no dispositivo ISP 1 - B"" e sair dessa interface que estávamos com o comando exit. Vamos continuar no modo de configuração digitando router rip, que é o comando que usamos. Depois version 2.

Vamos ao no auto-summary, como o Léo nos explicou anteriormente. Agora, as redes que este roteador vai divulgar são network 150.1.1.4 e 150.1.1.8.

exit
router rip
version 2
no auto-summary
network 150.1.1.4
network 150.1.1.8

Acredito que agora podemos realizar um teste de conectividade do PC do pesquisador A com este servidor. Já configuramos a rota no roteador do Instituto InovaE, portanto, ele encaminhará o pacote para o roteador A. Ele deve alcançar o destino.

O que você acha?

Leonardo: Vamos tentar e analisar o que acontece.

Lucas: Clicando em "ISP 1 - B" e depois em "Command prompt". Rodamos:

ping 150.1.10

Agora, precisamos aguardar o resultado.

Pinging 150.1.1.10 with 32 bytes of data:

Request timed out.

Reply from 150.1.1.10: bytes-32 time-7ms TTL-125

Reply from 150.1.1.10: bytes-32 time-6ms TTL-125

Reply from 150.1.1.10: bytes-32 time-8ms TTL-125

O primeiro não teve sucesso. O segundo, terceiro e quarto tiveram êxito. A conectividade foi obtida com sucesso.

Leonardo: Portanto, o protocolo RIP nos auxiliou a cumprir eficazmente essa função de trocar pacotes. No entanto, dei uma analisada nele e ele possui algumas limitações.

Lucas: Sim, Léo. O protocolo RIP é mais utilizado em redes de pequeno porte. Isso porque o protocolo RIP utiliza um algoritmo de vetor de distância que determina a melhor rota para encaminhamento de pacotes com base no número de roteadores pelos quais esses pacotes devem trafegar na rede.

Se tivéssemos um link conectando o roteador do Instituto InovaE diretamente ao roteador B do provedor de serviços e tivéssemos o protocolo RIP configurado nesses três roteadores, como seria o processo de escolha da melhor rota?

No que diz respeito à conexão do computador do pesquisar A ao servidor do provedor de serviços. O RIP decidiria o caminho ideal com base no número de roteadores que estivessem envolvidos nessa rota.

O critério que ele utiliza é baseado em "hops" (saltos). E observe que, mesmo que os links (conexões) que conectam o roteador do Instituto InovaE com o roteador A e com o roteador B tenham alta velocidade, o RIP ainda assim selecionaria a rota direta entre o roteador do Instituto InovaE e o roteador B para encaminhar esse pacote.

Então, ele não leva em consideração nem a latência e nem a velocidade do link de conexão, mas apenas o número de saltos que o pacote deveria dar no meio do caminho.

O RIP não considera a latência nem a velocidade, apenas o número de roteadores.

Leonardo: Isso é um problema nas redes de hoje em dia, que contam com alta velocidade.

Como podemos lidar com redes maiores ou quando a velocidade do link é muito importante e nós desejamos considerar o critério de velocidade, de latência e não apenas o caminho?

Lucas: Podemos usar um outro protocolo conhecido como OSPF. Vamos analisá-lo na prática na sequência?

Sobre o curso Redes: implementando roteamento, DNS e IPv6

O curso Redes: implementando roteamento, DNS e IPv6 possui 119 minutos de vídeos, em um total de 51 atividades. Gostou? Conheça nossos outros cursos de Redes em DevOps, ou leia nossos artigos de DevOps.

Matricule-se e comece a estudar com a gente hoje! Conheça outros tópicos abordados durante o curso:

Aprenda Redes acessando integralmente esse e outros cursos, comece hoje!

Plus

De
R$ 1.800
por
12X
R$109
à vista R$1.308
  • Acesso a TODOS cursos por 1 ano

    Formações com mais de 1500 cursos atualizados e novos lançamentos semanais, em Programação, Inteligência Artificial, Front-end, UX & Design, Data Science, Mobile, DevOps e Inovação & Gestão.

  • Certificado

    A cada curso ou formação concluído, um novo certificado para turbinar seu currículo e LinkedIn.

  • Mentorias com especialistas

    No Discord, você tem acesso a eventos exclusivos, grupos de estudos e mentorias com especialistas de diferentes áreas.

  • Comunidade exclusiva

    Faça parte da maior comunidade Dev do país e crie conexões com mais de 120 mil pessoas no Discord.

  • Acesso ao conteúdo das Imersões

    Acesso ilimitado ao catálogo de Imersões da Alura para praticar conhecimentos em diferentes áreas.

  • App Android e iOS para estudar onde quiser

    Explore um universo de possibilidades na palma da sua mão. Baixe as aulas para assistir offline, onde e quando quiser.

Matricule-se

Pro

De
R$ 2.400
por
12X
R$149
à vista R$1.788
  • Acesso a TODOS cursos por 1 ano

    Formações com mais de 1500 cursos atualizados e novos lançamentos semanais, em Programação, Inteligência Artificial, Front-end, UX & Design, Data Science, Mobile, DevOps e Inovação & Gestão.

  • Certificado

    A cada curso ou formação concluído, um novo certificado para turbinar seu currículo e LinkedIn.

  • Mentorias com especialistas

    No Discord, você tem acesso a eventos exclusivos, grupos de estudos e mentorias com especialistas de diferentes áreas.

  • Comunidade exclusiva

    Faça parte da maior comunidade Dev do país e crie conexões com mais de 120 mil pessoas no Discord.

  • Acesso ao conteúdo das Imersões

    Acesso ilimitado ao catálogo de Imersões da Alura para praticar conhecimentos em diferentes áreas.

  • App Android e iOS para estudar onde quiser

    Explore um universo de possibilidades na palma da sua mão. Baixe as aulas para assistir offline, onde e quando quiser.

  • Luri, a inteligência artificial da Alura

    Luri é nossa inteligência artificial que tira dúvidas, dá exemplos práticos, corrige exercícios e ajuda a mergulhar ainda mais durante as aulas. Você pode conversar com a Luri até 100 mensagens por semana.

  • Alura Língua - Inglês e Espanhol

    Aprenda um novo idioma e expanda seus horizontes profissionais. Cursos de Inglês, Espanhol e Inglês para Devs, 100% focado em tecnologia.

Matricule-se

Ultra

12X
R$209
à vista R$2.508
  • Acesso a TODOS cursos por 1 ano

    Formações com mais de 1500 cursos atualizados e novos lançamentos semanais, em Programação, Inteligência Artificial, Front-end, UX & Design, Data Science, Mobile, DevOps e Inovação & Gestão.

  • Certificado

    A cada curso ou formação concluído, um novo certificado para turbinar seu currículo e LinkedIn.

  • Mentorias com especialistas

    No Discord, você tem acesso a eventos exclusivos, grupos de estudos e mentorias com especialistas de diferentes áreas.

  • Comunidade exclusiva

    Faça parte da maior comunidade Dev do país e crie conexões com mais de 120 mil pessoas no Discord.

  • Acesso ao conteúdo das Imersões

    Acesso ilimitado ao catálogo de Imersões da Alura para praticar conhecimentos em diferentes áreas.

  • App Android e iOS para estudar onde quiser

    Explore um universo de possibilidades na palma da sua mão. Baixe as aulas para assistir offline, onde e quando quiser.

  • Luri, com mensagens ILIMITADAS

    Mensagens ilimitadas para estudar com a Luri, a IA da Alura, disponível 24hs para tirar suas dúvidas, dar exemplos práticos, corrigir exercícios e impulsionar seus estudos.

  • Luri Vision, a IA que enxerga suas dúvidas

    Envie imagens para a Luri e ela te ajuda a solucionar problemas, identificar erros, esclarecer gráficos, analisar design e muito mais.

  • Alura Língua - Inglês e Espanhol

    Aprenda um novo idioma e expanda seus horizontes profissionais. Cursos de Inglês, Espanhol e Inglês para Devs, 100% focado em tecnologia.

  • 6 Ebooks da Casa do Código

    Receba cupons da Casa do Código, a editora da Alura, e escolha ebooks que acompanharão a sua jornada de aprendizado para sempre.

Matricule-se
Conheça os Planos para Empresas

Acesso completo
durante 1 ano

Estude 24h/dia
onde e quando quiser

Novos cursos
todas as semanas